home/nixos/machines/foxhut/boot.nix

38 lines
1.1 KiB
Nix

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
{ pkgs, pkgs-unstable, asahi-firmware, ... }:
{ config, ... }:
{
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = false;
hardware.asahi.peripheralFirmwareDirectory = asahi-firmware;
hardware.asahi.enable = true;
hardware.asahi.setupAsahiSound = true;
hardware.asahi.useExperimentalGPUDriver = true;
hardware.asahi.experimentalGPUInstallMode = "replace";
fileSystems.foxshare = {
fsType = "exfat";
device = "/dev/disk/by-label/foxshare";
mountPoint = "/home/xenia/foxshare";
options = ["uid=${builtins.toString config.users.users.xenia.uid}" "nofail"];
};
swapDevices = [{
device = "/swap";
size = 16 * 1024; # 16GB
}];
environment.systemPackages = (with pkgs-unstable; [
renoise
]) ++ (with pkgs; [
prismlauncher
]);
}