templates/flake.nix

57 lines
1.5 KiB
Nix

{
description = "Some flake templates";
outputs = { self, nixpkgs }: {
templates.minimum = {
path = ./minimum;
description = "Minimal sane flake";
welcomeText = "mjau";
};
templates.rust = {
path = ./rust;
description = "Minimal flake for rust with overlay and devshell";
welcomeText = "mjau 🦀🦀🦀";
};
templates.haskell = {
path = ./haskell;
description = "Minimal flake for Haskell with nix build system and devshell";
welcomeText = "mjau λλλ";
};
templates.jupyter = {
path = ./jupyter;
description = "A jupyter flake, with a custom haskell kernel and proper pdflatex LaTeX export supoprt";
welcomeText = "mjau 🐍🐍🐍";
};
templates.python = {
path = ./python;
description = "Minimal python flake";
welcomeText = "hisss 🐍🐍🐍";
};
templates.verilog = {
path = ./fpga;
description = "FPGA flake, running verilog on ice40";
welcomeText = "mjau 🧊";
};
templates.julia = {
path = ./julia;
description = "Minimal julia flake";
welcomeText = ":3";
};
templates.idris2 = {
path = ./idris2;
description = "Minimal idris2 flake";
welcomeText = "mjau :3";
};
templates.c = {
path = ./c;
description = "Minimal c flake";
welcomeText = "sorry";
};
templates.ocaml = {
path = ./ocaml;
description = "Minimal ocaml flake";
welcomeText = "bonjour";
};
};
}